Issue with Installation


#1

Hello! I keep getting this error when I attempt to install Anbox. The following errors occur when I attempt to run normally and with sudo, respectively.
snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks
cannot change profile for the next exec call: No such file or directory
I’m running Xubuntu 16.04 (GalliumOS, based off of Xubuntu)


#2

I guess the reason here is that the snap-confine binary in Ubuntu has AppArmor support enabled but your kernel from GalliumOS misses certain patches to confine snaps properly. All pending AppArmor patches are meant to land in the 4.14 upstream release of the kernel. So as long as that isn’t out your only option is to switch to an Ubuntu based kernel on an Ubuntu based operating system :slight_smile:


#3

I really wish I could switch kernals, but that’s not much of an option seeing as how driver support on other Linux distributions for Chromebooks is very limited. GalliumOS, being made for linux, is the best I got sadly. :c


#4

mastermind is correct here. You need those patches in order the get snaps in general working.


#5

Hi! Has there been any other methods of getting snap on this machine? Like, is there a way to install the patches or anything?